High ACPI.SYS DPC latency ?

PC Configurations, motherboards, etc, etc

Moderators: valis, garyb

Post Reply
@plonter
Posts: 38
Joined: Thu Dec 18, 2008 6:43 am

High ACPI.SYS DPC latency ?

Post by @plonter »

Hi

I will describe my Scope 7 setup to begin with...

Scope 7 is working on a Desktop PC and running 3 Pci cards Luna, Pulsar 2, Scope/Sp
The three cards is installed in ASUS TUF H310-PLUS GAMING motherboard

As for DAW, the setup is a Lenovo Legion Y530 Laptop that communicates with Scope 7 via RME Digiface USB true 32 channels on ADAT cables.
And Synergy software for one mouse and keyboard sharing.

This setup working excellent :) but one thing keeps me awake at night is the DPC Latency in the Lenovo Laptop from ACPI.SYS driver, please see photo.
DPC ACPI HIGH.PNG
DPC ACPI HIGH.PNG (55.86 KiB) Viewed 1773 times
Can i please ask for guidance on how to reduce this high DPC Latency?

Things i have tried and no change:

1 - Disabled Wifi card and Ethernet

2 - Update BIOS

3 - Disabled "Microsoft ACPI-Compliant Control Method Battery"

4 - Disabled C State

5 - Disabled Fast boot

6 - Disabled Onboard sound card

7 - Disabled Hyperthreading

8 - Win 10 is on the latest update

Plus i have access to the advanced BIOS settings for the Laptop, and there i see a lot of things related to ACPI but have no knowledge what i can disable or change values.

Any advice or thing to try I'm very open to :)

Thanks.

Best,
jksuperstar
Posts: 1615
Joined: Mon Nov 15, 2010 12:57 pm

Re: High ACPI.SYS DPC latency ?

Post by jksuperstar »

I used to use a Lenovo laptop,and had some similar issues. Mine stemmed from the power management of the laptop. The laptop scales back the processor power/frequency when it's not needed, automatically.

To verify this is it, install CPU-Z, and then take note of each processor's frequency. They probably get scaled down to 800MHz or so.

Then find a power profile that is for full performance, and forces the CPUs not to scale back frequency. This is different from the other settings, because laptops can be aggressive about power management, and basically get rated based on battery life, etc. You might just find a profile in your power settings ( typically there is a battery profile, a balanced profile, etc). Try the Performance profile, or find one on the Internet, or try to create one. Then check CPU-Z again if the CPU frequency stays consistently at the max freq. For this to work, you may need to have the laptop plugged in, since some laptops can't stay at max freq on battery alone. Good Luck!
Post Reply